Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Closed) > Archived Posts > DivX/XviD Conversion/Encoding

 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 27 May 2002, 02:32 PM   #1
Junior Member
Junior Member
 
Join Date: Dec 2001
Posts: 23
Unhappy error message...

I often get the following error when opening a file in VirtualDub:

VirtualDub has detected an improper VBR audio encoding in the source AVI file and will rewrite the audio header with standard CBR values during processing for better compatibility. This may introduce up to 3303ms of skew from the video stream. If this is unacceptable, decompress the *entire* audio stream to an uncompressed WAV file and recompress with a constant bitrate encoder. (bitrate: 181.8 += 19.4 kbps)

Can anyone tell me what this means? And what I should do? I have found with files like this I get audio problems after converting them to mpgs with TMPGE. Please help.

THANKS!
chakotay2 is offline  
Old 27 May 2002, 03:44 PM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

That's the message you get when the audio was encoded as Variable Bit Rate (VBR) .MP3 rather than the more conventional Constant Bit Rate (CBR) .MP3. TMPGEnc cannot handle VBR.

Do the following, in order to convert .AVIs with VBR-MP3 Audio

Simply use VirtualDub to save the audio stream as an Uncompressed PCM (WAV) file as follows:
Load your original .AVI into VirtualDub
From the "File" dropdown menu, select "Save WAV" (Enter a new filename with a ".WAV" extender).Click on "OK"
Then set "Video" to "Direct Stream Copying"
Then save the .AVI as a silent .AVI (set "Audio" to "No audio" after you've saved the WAV file).

Then close VirtualDub and restart it
Set "Audio" to "No audio"
Load your silent .AVI
Set "Video" to "Direct Stream Copying"
Under "Audio" click on "WAV Audio" and load your .WAV
Set "Audio" to "Full Processing Mode"
From the "Audio" dropdown menu, select "Compression" and choose the appropriate .MP3 settings. Click on "OK"
From the "File" dropdown menu, select "Save as AVI" and save your file with a new filename.
setarip is offline  
Old 27 May 2002, 03:58 PM   #3
Junior Member
Junior Member
 
Join Date: Dec 2001
Posts: 23
Default thanks

I'll try it. Thanks for the suggestion.
chakotay2 is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 12:13 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com