Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Closed) > Archived Posts > DivX/XviD Conversion/Encoding

 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 22 Oct 2002, 02:48 PM   #1
Junior Member
Junior Member
 
Join Date: Oct 2002
Posts: 5
Unhappy Help I get no sound when encoding avi's

I have some AVI files that I am trying to convert to VCD format. I use TMPEGenc 2.5 to convert these files and burn them with nero. Most of the files work fine but some do not have any sound????? The AVI file has sound but after using TMPEG the MPEG comes out with no sound. If I look at the file before I convert it I can tell if it will have sound by looking at the green bar that indicates the sound at the bottom of the screen. Seems that about 1 out of ever 3 files will convert to mpeg but lack the sound. Is there any other program that will convert these AVI's correctly, or is it something I am doing wrong? If I have to I can use nero to encode but the flies are to long and I don't know any other way to convert them besides using TMPEG. Maybe there is another program that would work better?????? Thanks for any help you can give me.
matejag5 is offline  
Old 22 Oct 2002, 03:09 PM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Chances are that the "problem" files include .AC3 audiostreams, which TMPGEnc will not extract from an .AVI file. If this is the case, you'll have to extract and convert the audiostream to a separate .WAV file as follows:

**IMPORTANT - VirtualDub v.1.4AC3 is a specific MODIFIED version of VirtualDub!

Load the .AVI file into VirtualDub v1.4C-AC3, set "Video" to "Direct Stream Copying" and select (under "File") "Save .WAV/.AC3" - and save as .AC3 (IMPERATIVE to save as .AC3!).

Despite the fact that .AC3 file extracted using VDub-AC3 doesn't play properly, PX3AC3Converter will do a perfect job of converting it to .WAV format.

You can then load the .AVI (FIRST) into TMOGEnc and then load the .WAV file.

Let us know of your success ;>}
setarip is offline  
Old 23 Oct 2002, 09:40 AM   #3
Junior Member
Junior Member
 
Join Date: Oct 2002
Posts: 5
Smile Found a way to do it thanks

I am using Virtual Dub to make new AVI files from the AVI files I have. The files that were coming out with no sound must have been something different than DIVX format. I just changed the settings to DIVX 5.02 format and then "save as avi". once it is this type of AVI it coverts just fine to vcd format with TMPEGenc. Thanks for your help
matejag5 is offline  
Old 23 Oct 2002, 09:51 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Whatever works! Congratulations on resolving your dilemma ;>}
setarip is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 04:18 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com