Digital Video Forums  

Go Back   Digital Video Forums > Disc Formats > DVD Authoring and Editing

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 12 Jul 2003, 08:52 PM   #1
Junior Member
Junior Member
 
Join Date: Jul 2003
Posts: 7
Unhappy Still No Audio

Hi,

I have used tmpgenc to try and convert an .avi file to mpeg format so I can put it on a DVD.

When I create a project, I add the .avi file into the Video source box, but it will not let me add the .avi file into the audio source box.

I try anyway and the output is then a .mp2 and a .wav file. The .mp2 video file is fine, but there is no audio on the .wav.

Could someone please explain in simple terms, what I am doing wrong, and how can i fix it so I have a film with audio

Cheers

Nige
nigeh is offline   Reply With Quote
Old 13 Jul 2003, 04:20 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

1) Load the .AVI file into VirtualDub (or any of its variants) or NanDub

2) From the "File" dropdown menu, select "File Information"

3) Post (here) EVERYTHING you see (both video and audio information), or post a screen capture .jpg of the information box


The audiostream is probably in either .AC3 format or Variable Bitrate MPEG Layer 3 (VBR .MP3).

If it proves to be .AC3:

In TMPGEnc, under the "Environmental Settings" "VFAPI plugin" tab rightclick on the "Direct Show Multimedia Reader" and increase to the highest priority. This will enable TMPGEnc to accept a properly encoded .AVI with .AC3 audio for input...


If it proves to be VBR:

Converting .AVIs with VBR-MP3 Audio

Simply use NanDub (or VirtualDubMod) to save the audio stream as an Uncompressed PCM (WAV) file as follows:
Load your original .AVI into NanDub
Set "Video" to "Direct Stream Copy"
Set "Audio" to "Full Processing Mode"
From the "Audio" dropdown menu, select "Compression" and choose - and choose "No compression(PCM)"
From the "File" dropdown menu, select "Save WAV" (Enter a new filename with a ".WAV" extender).Click on "OK"
Then save the .AVI as a silent .AVI (set "Audio" to "No audio" after you've saved the WAV file).
Open TMPGEnc and "drag and drop" the silent .AVI onto it, then do the same with the .WAV file
setarip is offline   Reply With Quote
Old 14 Jul 2003, 12:57 AM   #3
Junior Member
Junior Member
 
Join Date: Jul 2003
Posts: 7
Default

Attatched is the properties for the movie I am working on
Attached Thumbnails
Still No Audio-properties-virtualdub.jpg  
nigeh is offline   Reply With Quote
Old 14 Jul 2003, 01:31 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Your file contains an .AC3 audiostream.

1) If you don't already have one, download and install an .AC3 codec

2) Then , as per my instructions above:

In TMPGEnc, under the "Environmental Settings" "VFAPI plugin" tab rightclick on the "Direct Show Multimedia Reader" and increase to the highest priority. This will enable TMPGEnc to accept a properly encoded .AVI with .AC3 audio for input...
setarip is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 01:02 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com