Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Closed) > VirtualDub

 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 25 Oct 2009, 08:11 AM   #1
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default Virtualdub or AC-3 Decompressor not working w/ Windows 7???

Hey guys:

I can't get Virtualdub to work in harmony with AC-3 Decompressor and Windows 7 64-bit? Windows 7 says it doesn't see a decompressor source. Is there a workaround for this?? Possibly another decompressor program???

Thanks

Last edited by jwmghf; 25 Oct 2009 at 10:26 AM
jwmghf is offline  
Old 25 Oct 2009, 09:23 AM   #2
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

maybe you could try ffdshow (there are also 64 bit versions but 32 runs fine) for the ac3 decoding job under win7/64
__________________
UncasMS is offline  
Old 25 Oct 2009, 09:58 AM   #3
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default

I tried FFDShow and Xvid but virtualdub says it cant find the ac-3 decompressor. So I don't think that AC-3 Decompressor program is actually loading up. When I right click on the AC3ACM and hit the install, I do see the cmd box open momentarily and then close, so I don't know??? Is there a different compressor program??

Thanks
jwmghf is offline  
Old 25 Oct 2009, 10:40 AM   #4
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

WHEN does vd say so / trying which operation?

i downloaded a vd_64 bit version this minute and loaded an avi file which has ac3 in it and when loading the file file MY version does not complain using win7/64

i have ffdshow(64bit) installed and checked that its internal audo config showed that ac3 was handled

Last edited by UncasMS; 25 Oct 2009 at 10:44 AM
UncasMS is offline  
Old 25 Oct 2009, 11:16 AM   #5
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

ok, i think i now see what your problem is

when trying to save this file i opened vd complained

i installed this ac3 filter and was able to decode
UncasMS is offline  
Old 25 Oct 2009, 11:16 AM   #6
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default

Here is what the error says exactly:

Couldn't locate decompressor for format 'XVID" (unknown)

VirtualDub requires a Video for Windows (VFW) compatible codec to decompress video. DirectShow codecs, such as those used by Windows Media Player, are not suitable.


This error comes up after I have loaded the avi, and do all the steps I would normally do to create a wav file for input to T
jwmghf is offline  
Old 25 Oct 2009, 11:19 AM   #7
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

did you see my second reply above yours?

+++

so now we also have trouble decoding the video as well???

hmm, no such trouble here

try ffdshow pls it should really do the job
UncasMS is offline  
Old 25 Oct 2009, 11:27 AM   #8
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

shark007's win 7 filters may also be worth a closer look
UncasMS is offline  
Old 25 Oct 2009, 12:32 PM   #9
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default

I'm still having the same problems. Now I get that error as soon as I load the avi. I am going to try another avi with ac-3. Windows media player won't open it up either. But media player classic will? I will do a full uninstall and re-install and post back a little later. I am frustrated!!! Thanks for helping me out.
jwmghf is offline  
Old 25 Oct 2009, 09:02 PM   #10
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

so far i have no such problems here

installed media playere classic home cinema 64bit, ffdshow (32+64) and the said vd 64 version and playing as well as opening/saving via vd works

good luck

Last edited by UncasMS; 25 Oct 2009 at 09:04 PM
UncasMS is offline  
Old 26 Oct 2009, 02:16 AM   #11
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default

Thanks man:

I will post back and let you know how I make out. Enjoy the rest of your weekend!!!
jwmghf is offline  
Old 27 Oct 2009, 02:18 PM   #12
Junior Member
Junior Member
 
Join Date: Oct 2009
Posts: 1
Default

Hi guys... I wonder if anyone can help. I have windows 7 x64 here, and installed FFDShow x86 and x64. I also installed Haali Media Splitter cause I needed it for SubtitleWorkshop to work. Now I've installed VirtualDub x64 and i get the "no audio decompressor could be found to decompress the source audio format" when trying to play an avi with AC3 audio. I do not want to install another codec, i would like it to work with FFDShow, which does play fine in MPC and other apps. Any help?

EDIT: I can work with AVIs with, say, MP3 audio. But the FFDShow icons don't appear. That means VirtualDub isn't using FFDShow, right?
dronkit is offline  
Old 27 Oct 2009, 10:03 PM   #13
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

i have linked to the ac3 codec provided by alexander vogovsky, who knows his stuff for years

give it a go
UncasMS is offline  
Old 28 Oct 2009, 01:30 AM   #14
Gold Member
Gold Member
 
Join Date: Oct 2004
Posts: 134
Default

I think the problem is that the ac-3 decompression program is not loading up properly. dronkit, after you install it go to add/remove and remove it. I bet it tells you that there's a problem and the program looks like it has been uninstalled already. That's what I'm getting... and it's really aggravating!!! Hopefully, it can be fixed.
jwmghf is offline  
Old 28 Oct 2009, 02:18 AM   #15
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

jwmghf, are you saying that the ac3 filter from alexander vigovsky does NOT work for you?
UncasMS is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows File-Explorer Working Slowly OlldGranny General Computing 1 11 Nov 2007 09:56 AM
VirtualDub -> "NO AUDIO DECOMPRESSOR FOUND!" insc Other Software 1 17 Jan 2004 07:36 AM
VirtualDub says "decompressor: Divx;) MPEG-4 Fast Motion"? ziva Other File Formats 1 14 Feb 2003 08:00 AM



All times are GMT +10. The time now is 05:28 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com