Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > AVI, DivX/Xvid

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 25 Dec 2002, 05:01 PM   #1
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default How to convert XviD back into DivX?

I have this problem that whenever I try to convert a XviD into a smaller resolution to fit on my Archos Multimedia, the quality is pretty bad compared to my other movies that were converted the same way but weren't XviD, and also the sound is off and its really annoying hearing everythnig 10 seconds later. I want to know how I can convert XviD files back into a DivX file.
DarkDeath is offline   Reply With Quote
Old 26 Dec 2002, 05:42 PM   #2
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

anyone help me?
DarkDeath is offline   Reply With Quote
Old 26 Dec 2002, 06:31 PM   #3
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default

1. Open AVI file in Virtual/nandub.
2. Set Video tab to Full Processing Mode and Audio tab to Direct Stream Copy.
3. Under Video, select Compression and choose the DivX codec. Configure the settings, as required.
4. Under Audio, go to Interleaving and input the appropriate value in the 'Delay Audio by x ms' box
5. If the source resolution is not divisible by 16, you will need to resize it to conform to the factor-of-16 requirement. Use the Resize filter with Precise Bicubic mode.
6. Go to File -> Save as AVI and give a name to the new file.

Hope that will help you get started.
Enchanter is offline   Reply With Quote
Old 27 Dec 2002, 08:26 AM   #4
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

when I do that, the frames seem to skip a lot making the sound off track
DarkDeath is offline   Reply With Quote
Old 27 Dec 2002, 08:37 AM   #5
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default

To correct the off-synch audio in your resultant AVI file:
1. Load up AVI file in Virtual/nandub
2. Set both Video and Audio tabs to Direct Stream Copy
3. Under Audio, go to Interleave and input the appropriate value in the 'Delay audio track by x ms' box
4. Go to File -> Save as AVI and give a name to the new file

In the case of the audio gradually getting more and more off-synch from the video, add the following step prior to saving the file:
-. Under Video, go to Frame Rate and select "Change so video and audio durations match (you should see a value similar to the original frame rate).
Enchanter is offline   Reply With Quote
Old 27 Dec 2002, 10:01 AM   #6
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

in the frame rate, the video/audio durations match is about 9612 fps which I don't think is normal
DarkDeath is offline   Reply With Quote
Old 27 Dec 2002, 11:17 AM   #7
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default

Quote:
Originally posted by DarkDeath
in the frame rate, the video/audio durations match is about 9612 fps which I don't think is normal
Skip the frame rate step and see if you still suffer from off-synch audio...
Enchanter is offline   Reply With Quote
Old 27 Dec 2002, 12:24 PM   #8
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

I'm not sure what to do for this step

Under Audio, go to Interleave and input the appropriate value in the 'Delay audio track by x ms' box

also, it seems that the video frames speed up and skip making the audio off track
DarkDeath is offline   Reply With Quote
Old 27 Dec 2002, 01:31 PM   #9
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

If, as it appears, the procedures delineated by enchanter are not yielding satisfactory results, you might want to "go back to Step 1", modified as follows (which should eliminate the out of synch problem):

Simply use VirtualDub (or NanDub) to save the audio stream as an Uncompressed PCM (WAV) file as follows:
1) Load your original .AVI into VirtualDub
2) From the "File" dropdown menu, select "Save WAV" (Enter a new filename with a ".WAV" extender).Click on "OK"
3) Then set "Video" to "Full Processing Mode" - and from the "Video" dropdown menu, select "Compression" and configure the DivX codec to your desired settings
4) Then save the .AVI as a silent .AVI (set "Audio" to "No audio" after you've saved the WAV file).

5) Then close VirtualDub and restart it
6) Set "Audio" to "No audio"
7) Load your silent .AVI
8) Set "Video" to "Direct Stream Copying"
9) Under "Audio" click on "WAV Audio" and load your .WAV
10) Set "Audio" to "Full Processing Mode"
11) From the "Audio" dropdown menu, select "Compression" and choose the appropriate .MP3 settings. Click on "OK"
12) From the "File" dropdown menu, select "Save as AVI" and save your file with a new filename.

When you're satisfied that the new file is good, feel free to delete the separate (large) .WAV audio file...

Let us know of your success ;>}
setarip is offline   Reply With Quote
Old 28 Dec 2002, 01:10 PM   #10
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

I need some help on DivX compression, can you explain the difference between 2-pass and 1-pass... When I compress back into DivX, the file size is fairly large
DarkDeath is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 03:21 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com