Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > AVI, DivX/Xvid

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 1 Nov 2002, 10:25 PM   #1
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Angry MPEG1 to DivX

I use PowerVCR II to capture my tv shows which are recorded in MPEG1 format. When I play┤em (.mpg) in Windows Media everything works well: audio and video are synchronized.

However this file type is too large and I change the format to AVI using NanDub and DivX + MP3 encoding. Every thing works worse: audio and video desynchronize even using Nundubs frame rate control to force a sync.



What should I do to get a sync?

Note: My hardware is a Duron 1000 MHz 256 MB RAM HD 40 GB 7200 RPM GeForce 2 64MB SoundBlaster Live! 5.1

Please, HEEEEELLLLPPPPP!
bodyslicer is offline   Reply With Quote
Old 2 Nov 2002, 12:52 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

When you first convert to DivX-compressed .AVI, set the audio to PCM (Uncompressed .WAV) audio at 48,000Hz. (This will create a file which is in excess of 1Gig in size,but not to worry, since this is an intermediate file that you'll subsequently eliminate.). Then close NanDub and restart it. Load this new file. Set "Video" to "Direct Stream Copying" and "Audio" to "Full Processing Mode". Select your .MP3 audio settings and save with a new name.

You can then delete the version with PCM audio.

Let us know of your success ;>}
setarip is offline   Reply With Quote
Old 2 Nov 2002, 08:39 AM   #3
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Default

Tnx, setarip, I┤ll try that. Just one mor information: may I put the video and audio in same avi file or should┤em be saparated?

Tnx again,
Slicer Man

PS. I┤ll try this workaround at monday.



Quote:
Originally posted by setarip
When you first convert to DivX-compressed .AVI, set the audio to PCM (Uncompressed .WAV) audio at 48,000Hz. (This will create a file which is in excess of 1Gig in size,but not to worry, since this is an intermediate file that you'll subsequently eliminate.). Then close NanDub and restart it. Load this new file. Set "Video" to "Direct Stream Copying" and "Audio" to "Full Processing Mode". Select your .MP3 audio settings and save with a new name.

You can then delete the version with PCM audio.

Let us know of your success ;>}
bodyslicer is offline   Reply With Quote
Old 2 Nov 2002, 12:13 PM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

"may I put the video and audio in same avi file?"

Absolutely ;>}
setarip is offline   Reply With Quote
Old 3 Nov 2002, 09:08 PM   #5
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Default

Quote:
Originally posted by setarip
"may I put the video and audio in same avi file?"

Absolutely ;>}

Hi setarip,

Didn┤t work: I┤ve compressed the video in divx format with audio pcm. It played desync. Then I┤ve converted de audio to mp3 and baoth audio and video remained desync. I┤ve tried using video framerate conversion to match┤em but didin┤t work.

Well, what else can i do? I use power vcr II v3 for capturing. The audio can be captured only in mp3 format (this software has no other option for audio enconding, neither PCM).

Tnx,

Slicer Man

bodyslicer is offline   Reply With Quote
Old 4 Nov 2002, 05:06 AM   #6
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Try using the free capture software included in VirtualDub (.AVI format)- and capture audio as Uncompressed PCM (.WAV) at 48,000Hz. Capture video using a lossless codec such as HuffyUV (If you try to capture using a DivX codec you'll drop far too many frames).

You can then use VirtualDub to compress both video and audio simultaneously...

Last edited by setarip; 4 Nov 2002 at 05:10 AM
setarip is offline   Reply With Quote
Old 4 Nov 2002, 10:15 AM   #7
Junior Member
Junior Member
 
vali's Avatar
 
Join Date: Oct 2002
Location: bucharest
Posts: 13
Default

Quote:
Originally posted by setarip
When you first convert to DivX-compressed .AVI, set the audio to PCM (Uncompressed .WAV) audio at 48,000Hz. (This will create a file which is in excess of 1Gig in size,but not to worry, since this is an intermediate file that you'll subsequently eliminate.). Then close NanDub and restart it. Load this new file. Set "Video" to "Direct Stream Copying" and "Audio" to "Full Processing Mode". Select your .MP3 audio settings and save with a new name.

You can then delete the version with PCM audio.

Let us know of your success ;>}
tried to compress a mpeg-1 720 x 576 with virtual dub, setting full processing mode >divx 5.02 and audio >full processing mode >uncompressed wav and it worked just fine.

after i just set video >direct stream copy and audio > full processing mode > mpeg-layer-3 (or whatever) and it worked just fine.
vali is offline   Reply With Quote
Old 5 Nov 2002, 12:29 AM   #8
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Default



Well guys, thank you all. I'll try your suggestions and post a reply of my success.


The Slicer Man
bodyslicer is offline   Reply With Quote
Old 13 Nov 2002, 12:51 AM   #9
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Question

Hi, setarip, it's me again

Now everything syncs well but when my videos are greater than about 20 minuts, the dub process stops. When I capture some video, the files strip near 20 minuts. Is there any reason for that? it seams to be happening with every video software in my computer...

Slicer Man

bodyslicer is offline   Reply With Quote
Old 13 Nov 2002, 01:26 AM   #10
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

"the files strip near 20 minuts. Is there any reason for that? it seams to be happening with every video software in my computer."

If this is happening with more than one capture program, perhaps you're running out of hard drive space. If it's happening only with VirtualDub's capture program, check the settings (such as "Timing") under the "Capture" dropdown menu...


By the way, glad to hear my suggestion got you back into synch ;>}
setarip is offline   Reply With Quote
Old 16 Nov 2002, 11:10 PM   #11
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Default AAAAHHHHHH!



Hi setarip,

Sorry if i┤m anoying you but my head is blowing

The files already strips near 20 minuts and/or 600-700 MB of size
I have a HD 7400 RPM with 20gb of free space. I JUST FORMATED my HD, reinstaled WXP and the capture drivers and gordianknot 0.26. Then I capture video and the same shit occurs: the capturing job stops or the file strips. The I join the striped files in one and try to dub┤em to divx and the dub proccess stops near 20 minuts! My capture card is Prolink bt 878P+ R8E, Have a GForce 2 64mb tvout. All of them used to work well and I thoug it could be some WXP malfunction... then I reinstalled the system and got NOTHING!

Sorry again but i┤m near to kill someone! This is the last time I bore you about this matter but do you know who, where, when or how can I solve this??? Tnx,


Tired Slicer Man


Quote:
Originally posted by setarip
"the files strip near 20 minuts. Is there any reason for that? it seams to be happening with every video software in my computer."

If this is happening with more than one capture program, perhaps you're running out of hard drive space. If it's happening only with VirtualDub's capture program, check the settings (such as "Timing") under the "Capture" dropdown menu...


By the way, glad to hear my suggestion got you back into synch ;>}
bodyslicer is offline   Reply With Quote
Old 17 Nov 2002, 06:09 AM   #12
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

This is a long shot, but its truly the last thing I can think of:

If you've got a Creative Labs .MP3 audio codec installed, uninstall it. Various posts at these forums have indicated that this particular codec limits filesize to 9,995 frames. Install and use the radium .MP3 codec instead.

Let us know of your success ;>}
setarip is offline   Reply With Quote
Old 27 Nov 2002, 12:27 AM   #13
Junior Member
Junior Member
 
Join Date: May 2002
Posts: 17
Cool-2 GOD! TnX!

This is the question! I really use Creative's MP3 codec! Thank You for all. Now it works fine!

The Happy Slicer Man




Quote:
Originally posted by setarip
This is a long shot, but its truly the last thing I can think of:

If you've got a Creative Labs .MP3 audio codec installed, uninstall it. Various posts at these forums have indicated that this particular codec limits filesize to 9,995 frames. Install and use the radium .MP3 codec instead.

Let us know of your success ;>}
bodyslicer is offline   Reply With Quote
Old 27 Nov 2002, 01:30 AM   #14
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

My pleasure ;>}
setarip is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 12:03 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com