Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > AVI, DivX/Xvid

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 22 Apr 2002, 11:14 PM   #1
Junior Member
Junior Member
 
Join Date: Jan 2002
Posts: 25
Default no audio streaming?

I am having problems when cutting divx or avi. i am using v dub, and cut the movie and use direct streaming for both audio and video, however a few seconds into saving it as avi, the audio marker changes from audio streaming YES to NO. any ideas? please help
alancharmed is offline   Reply With Quote
Old 23 Apr 2002, 01:14 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

1) What version of VirtualDub are you using?

2) What video codec was used and what audio format was used to create the file? In order to determine this, do the following:

A) Load the file into VirtualDub

B) From the "File" dropdown menu, select "File Information"

C) Post (here) EVERYTHING you see (both video and audio information), or post a screen capture .jpg of the information box


"the audio marker changes from audio streaming YES to NO"

Just where are you seeing this?
setarip is offline   Reply With Quote
Old 23 Apr 2002, 07:08 PM   #3
Junior Member
Junior Member
 
Join Date: Jan 2002
Posts: 25
Default no audio streaming

file info is:

Video

frame size 720x480,23976fps (41708 u.s.)
# of frames 181548 (2.06.12)
decompressor divx mpeg4 fast motion
Number of keyframes 757
key frame size 1695/12264/36714/ (9067k)
delta key frame size 0/3111/49908/(549335)

Audio
sample rate 24000hz
channels 2 (stereo)
sample precision 0-bit
compression mpeg layer 3 (professional)
preload skew 27657 samples (1.155)
#of frames 1894
total frame size 27657/279999/28178/51789)k

As for where am i seeing it, when i click save as avi, and the progress window appears i click on the right hand tab and it shows optimizing for preview NO and the details of video and audio streaming, this is where it is changing from yes to no. loadsa info here, sorry, but hop yoiu can help. many thanks
alancharmed is offline   Reply With Quote
Old 24 Apr 2002, 03:31 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Your difficulty is probably arising as a consequence of the approximate 100:1 audio:video interleaving ratio (Audio frames 1,894 video frames 181,548 frames) - typically done to save a few Megs of filesize.

I'd suggest that you simply load the file into VirtualDub, set both "Audio" and "Video" to "Direct Stream Copying" and save the .AVI with a new filename. Since, by default, VirtualDub is set for 1:1 audio:video interleaving, the newly saved file should "behave properly" when cutting.

Let us know of your success ;>}
setarip is offline   Reply With Quote
Old 24 Apr 2002, 04:51 AM   #5
Junior Member
Junior Member
 
Join Date: Jan 2002
Posts: 25
Default

I tried it, alas, no joy, still changes from yes to no in the audio section. any other ideas ? cheers Alan
alancharmed is offline   Reply With Quote
Old 24 Apr 2002, 05:08 AM   #6
Digital Video Master
Digital Video Master
 
Join Date: Nov 2001
Posts: 1,309
Default

Sorry, I did not see, what version of Virtualdub are you using? Try to use v1.4.10



Techno
techno is offline   Reply With Quote
Old 24 Apr 2002, 05:57 AM   #7
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

I presume that the problem you're having is that either you get no audio for the second half, or the audio goes out of synch.

Does the original .AVI play properly ALL the way through (video and audio synchronized?

If it does, the only other suggestion I would have is:

1) Load the original .AVI into VirtualDub

2) From the "File" drodpown menu, select "Save as WAV" and enter a new filename with a ".WAV" extension

3) Then set "Audio" to "No Audio" and "Video" to "Direct Stream Copying" - and save this SILENT .AVI with a new filename

4) Close VirtualDub and then restart it (cautionary)

5) Load the SILENT .AVI

6) From under the "Audio" dropdown menu select "WAV audio" and load your .WAV file

7) Set "Video" to "Direct Stream Processing" and "Audio" to "Full Processing Mode"

8) From under the "Audio" dropdown menu, select "Conversion" - and choose either 22,050 or 44,100

9) From under the "Audio" dropdown menu, select "Compression" - and choose a corresponding MPEG Layer 3 (MP3) setting (either any of the 22,050 choices, if that's the conversion you chose, or any of the 44,100 settings, if that's the conversion you chose)

10) Save with a new filename
setarip is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 12:10 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com