Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > AVI, DivX/Xvid

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 31 Dec 2002, 11:25 AM   #1
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 5
Default Some Questions about, DivX, XVid, XMPEG, Flask and GKnot

Hi,

I have a little Problem with 2 pass encoding.
I first tried to encode a DVD with XMPEG to XVid with 2-pass encoding. A short time after the second pass begun XMPEG crashed. Okay - so I tried DivX (5.02) because I heard XVid is some kind of instable. Same Problem. So I changed to flask (0.7 - last build) and tried the same with XVid. Flask crashed. Okay ... Flask and DivX - crash !!!
Now I tried flask with XVid but I changed to single pass. Wow - It worked.
Here is what comes out:

Picture:
Width 688
Height 416
Audio:
Length 1:50:05
Bitrate 160 kbit/s
Audioformat MPEG Layer-3
Video:
Pic. Rate 25fps
Datarate 108kbit/s
length of videofile 24bit
Videocodec xvid

Size of File 702MB

This is what windows shows me in my explorer.

So I thought maybe there is a problem with flask and XMPEG. So I searched here and found something about gknot. Okay I thought. Let's give it a try. But as I can see gknot only supports DivX. So I used Divx with 2-pass encoding. And it worked.

Picture:
Width 512
Height 272
Audio:
Length 2:04:39 (it was the same movie - why is it longer)
Bitrate 116 kbit/s (I set it to 128 - why did he use 116)
Audioformat MPEG Layer-3
Video:
Pic. Rate 25fps
Datarate 94kbit/s
length of videofile 24bit
Videocodec DivX

Size of File 688MB

Okay - the second file is smaller. But the first file is a great quality. I thought that 2-pass enconding will reduce file size by same (or nearly) same quality.
I "think" I used the same setting with each tool.

So my questions are:
Is XVid better than DivX? (quality and file size)
Can gknot use XVid?
Is it (known) a bug that xmpeg and flask crashes with 2-pass encoding?
Is there a better tool to encode?

As u see I am a newbee to this. So maybe someone can point me to the right direction... thx in advance

Aalamar
aalamar is offline   Reply With Quote
Old 31 Dec 2002, 11:51 AM   #2
khp
The Other
 
khp's Avatar
 
Join Date: Nov 2001
Location: Online
Posts: 2,161
Default Re: Some Questions about, DivX, XVid, XMPEG, Flask and GKnot

Quote:
Originally posted by aalamar

Is XVid better than DivX? (quality and file size)
Only you can answer that.

Quote:
Originally posted by aalamar

Can gknot use XVid?
No GordianKnot can't use Xvid, but that does not mean that you can't use GordianKnot, to help you encode with XVID. You can find a guide on this at www.doom9.org

Quote:
Originally posted by aalamar

Is it (known) a bug that xmpeg and flask crashes with 2-pass encoding?
No, many people have successfully used xmpeg/flask for two pass encoding. If you get random crashes durring the encoding, it's most likely caused by system instablity, if it crashes immidiatly after starting encoding, it's most likely a config problem. If it crashes immidiaetly after starting the second pass, I would suspect that it's a problem with your audio conversion.

Quote:
Originally posted by aalamar

Is there a better tool to encode?
Better ?
__________________
Donate your idle CPU time for something usefull.
http://folding.stanford.edu/
khp is offline   Reply With Quote
Old 31 Dec 2002, 12:25 PM   #3
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default Re: Some Questions about, DivX, XVid, XMPEG, Flask and GKnot

Quote:
Originally posted by aalamar
Hi,

I have a little Problem with 2 pass encoding.
I first tried to encode a DVD with XMPEG to XVid with 2-pass encoding. A short time after the second pass begun XMPEG crashed. Okay - so I tried DivX (5.02) because I heard XVid is some kind of instable. Same Problem. So I changed to flask (0.7 - last build) and tried the same with XVid. Flask crashed. Okay ...
Disable Hinted ME from within XviD's configuration.
Enchanter is offline   Reply With Quote
Old 31 Dec 2002, 01:05 PM   #4
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 5
Default

Thx for ur help guys...

@Enchanter: it was turned off

@khp: It's immediately after beginning with pass 2. So I will do some testing. With other audio settings or completly without audio.

I'll be back after testing...

cu and thx
Aalamar
aalamar is offline   Reply With Quote
Old 1 Jan 2003, 06:56 AM   #5
Member
Member
 
HDRed's Avatar
 
Join Date: Dec 2002
Posts: 52
Default

aalamar, make sure you're not overclocking your CPU - this will make 2-pass mode crash if it's not 100% stable, especially if you set the program at a higher priority.

download prime95 and run that for about an hour - if it finds an error, there's your problem. if not, you have some sort of software incompatibility.
HDRed is offline   Reply With Quote
Old 1 Jan 2003, 07:50 AM   #6
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 5
Default

Thx ...

I am not overclocking. It is a boxed P4 2.53 with 1 GB RAM. Nothing overclocked. I will look for the tool and will do as u said.

I did a 2-pass scan with flask without audio decoding (Flask Options/Audio/Don't process audio). It crashed.

I found now that I have 2 MP3 codecs installed. don't know why but I think I have read something about it and that it will cause errors. But I don't know where and when I have read it.

I think I will first deinstall nimo codec pack and will look for the codec I need.

cu
Aalamar
aalamar is offline   Reply With Quote
Old 1 Jan 2003, 12:04 PM   #7
khp
The Other
 
khp's Avatar
 
Join Date: Nov 2001
Location: Online
Posts: 2,161
Default

You are using the automatic 2-pass option in Xmpeg right ?

Try doing a 1-pass encoding. If that works, try starting each of the two passes, in 2-pass encoding, individually (assuming that you didn't already do this).
khp is offline   Reply With Quote
Old 1 Jan 2003, 09:37 PM   #8
Junior Member
Junior Member
 
Join Date: Dec 2002
Posts: 5
Default

@khp - I think u were right with audio encoding problems. I did a 2 - pass without audio enconding (direct stream copy). It worked. After that I deinstalled nimo codec pack. I reinstalled the DivX Pro 5.02 codec and checked that there is only one mp3 codec installed. I am now at 9% at the second pass. Seems to work...

thx all
Aalamar
aalamar is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 11:06 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com