Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > Other File Formats

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 24 Nov 2002, 09:03 PM   #1
Junior Member
Junior Member
 
Join Date: Nov 2002
Location: Wellington, NZ
Posts: 9
Question-2 audio running too fast for video

Hey everyone, got a problem with the audio playing a few seconds (3-7secs) faster than the video.

I've used Virtual Dub and this is the info I've got.

Video stream:
Frame size, fps - 352x288, 29.970fps
# frames (time) - 95013 (52:50)
Decompressor - DivX 5.0.2 Codec
Number of key frames - 321
Min/avg/max/total key frame size - 586/6962/12564 (2183k)
Min/avg/max/total delta frame size - 0/3456/18445 (327974k)

Audio stream:
Sampling rate - 8000Hz
Channels - 2 (Stereo)
Sample precision - 16-bit
Compression - DivX Audio Compressor
Preload skew - 7 samples (0:00s)
# of frames - 49405
Min/avg/max/total frame size - 96/96/672 (4633k)


Any ideas? Will I need to re-encode the file, and how would I do that?
Huffer is offline   Reply With Quote
Old 25 Nov 2002, 01:51 AM   #2
Lord of Digital Video
Lord of Digital Video
 
Batman's Avatar
 
Join Date: Jan 2002
Location: Gotham City
Posts: 2,317
Default

Read articles on divx-digest.com or search this forum for potential solutions to synchronizing the audio and video streams.
Batman is offline   Reply With Quote
Old 25 Nov 2002, 07:14 AM   #3
Junior Member
Junior Member
 
Join Date: Nov 2002
Location: Wellington, NZ
Posts: 9
Talking-2

I've already read many of them, and they don't seem to help. I was told to post up the info from VirtualDub so that the community could lend me some advice?
Huffer is offline   Reply With Quote
Old 25 Nov 2002, 07:24 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

"Compression - DivX Audio Compressor"

1) Load the file into VirtualDub

2) Set both "Video" and "Audio" to "Direct Stream Copying"

3) From the "Audio" dropdown menu, select "Interleaving"

4) Change "Interleave audio every" to 500ms (NOT "frames")

5)Click on "OK"

6) Save with a new filename

Let us know of your success ;>}
setarip is offline   Reply With Quote
Old 25 Nov 2002, 09:07 PM   #5
Junior Member
Junior Member
 
Join Date: Nov 2002
Location: Wellington, NZ
Posts: 9
Default

setarip - thanks for the advice - I just tried doing all that you said, and I still came out with the same problem.

I've just noticed that the audio seems to be in sync for the first few minutes of the movie, but when I get to the end, it's about 6 seconds ahead of the video.

Any other ideas?
Huffer is offline   Reply With Quote
Old 25 Nov 2002, 09:30 PM   #6
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default

"Sampling rate - 8000Hz"
This kind of audio sampling rate is indeed always giving problems. I can't offer a definitive answer to your problem, but you might just try a few suggestions:
1. Similarly to the previous given steps, add this additional step: go to Video tab -> Frame Rate, and select 'Change so video and audio durations match.' OR
2. Upsample the audio to 44,100 Hz and remux it with the video, per instructions given.

Tell us how it goes.
Enchanter is offline   Reply With Quote
Old 26 Nov 2002, 08:34 PM   #7
Junior Member
Junior Member
 
Join Date: Nov 2002
Location: Wellington, NZ
Posts: 9
Default

hey everyone!
guess what, it worked! Vdub did the job, once I selected "audio & video durations match".

Thanks heaps for ALL your help! You've just made this movie watcher THAT much happier!
Huffer is offline   Reply With Quote
Old 28 Nov 2002, 12:53 PM   #8
Old member
 
Join Date: Feb 2002
Posts: 5,417
Default

Glad to see it worked.
Enchanter is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 02:17 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com