Digital Video Forums  

Go Back   Digital Video Forums > Video File Formats > Other File Formats

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 15 Jan 2003, 01:51 AM   #1
Junior Member
Junior Member
 
Join Date: Jan 2003
Posts: 3
Angry Audio/Video Synchronization Problem

I have a DivX movie file that plays perfectly in both the Windows Media Player and the DivX 2.0 Alpha Player. However, when I try to get it into a format so that I can burn it to a DVD the audio becoms desynchronized or there is no audio at all.

When I open the AVI file in VirtualDub 1.4.10 I get the following message --

VirtualDub has detected an improper VBR audio encoding in the source AVI file and will rewrite the audio header with standard CBR values during p rocessing for better compatabilty. This may introduce up to 89193 ms skew from the video stream. If this is unacceptable (which it is), decompress the *entire* audio stream to an uncompressed WAV file and recompress with a constant bitrate encoder. (bitrate: 113.5 + or - 28.2 kbps).

I have tried the above although I'm not sure I'm doing it right. The sound will then be fine at the beginning of the movie, but as it continues the sound slowly becomes out of synch with the video.

Has anyone encountered this problem before, and if so how did you rectify it?

Thanks for your help
TreeTopp
TreeTopp is offline   Reply With Quote
Old 15 Jan 2003, 02:03 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Simply use VirtualDub to save the audio stream as an Uncompressed PCM (WAV) file as follows:
Load your original .AVI into VirtualDub
From the "File" dropdown menu, select "Save WAV" (Enter a new filename with a ".WAV" extender).Click on "OK"
Then set "Video" to "Direct Stream Copying"
Then save the .AVI as a silent .AVI (set "Audio" to "No audio" after you've saved the WAV file).

Then close VirtualDub and restart it
Set "Audio" to "No audio"
Load your silent .AVI
Set "Video" to "Direct Stream Copying"
Under "Audio" click on "WAV Audio" and load your .WAV
Set "Audio" to "Full Processing Mode"
From the "Audio" dropdown menu, select "Compression" and choose the appropriate .MP3 settings. Click on "OK"
From the "File" dropdown menu, select "Save as AVI" and save your file with a new filename.
setarip is offline   Reply With Quote
Old 24 Feb 2003, 06:05 AM   #3
Junior Member
Junior Member
 
Join Date: Feb 2003
Posts: 10
Default

Quote:
Originally posted by setarip
Simply use VirtualDub to save the audio stream as an Uncompressed PCM (WAV) file as follows:
Load your original .AVI into VirtualDub
From the "File" dropdown menu, select "Save WAV" (Enter a new filename with a ".WAV" extender).Click on "OK"
Then set "Video" to "Direct Stream Copying"
Then save the .AVI as a silent .AVI (set "Audio" to "No audio" after you've saved the WAV file).

Then close VirtualDub and restart it
Set "Audio" to "No audio"
Load your silent .AVI
Set "Video" to "Direct Stream Copying"
Under "Audio" click on "WAV Audio" and load your .WAV
Set "Audio" to "Full Processing Mode"
From the "Audio" dropdown menu, select "Compression" and choose the appropriate .MP3 settings. Click on "OK"
From the "File" dropdown menu, select "Save as AVI" and save your file with a new filename.
Man you saved me again. Thanx 4 these tips, it finally works now!
YoDa2 is offline   Reply With Quote
Old 24 Feb 2003, 09:21 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default To YoDa2

"Man you saved me again. Thanx 4 these tips, it finally works now!"

My pleasure ;>}


Let's hope the information helped Tree Topp, the creator of this thread...
setarip is offline   Reply With Quote
Old 19 Jul 2003, 12:49 AM   #5
Junior Member
Junior Member
 
Join Date: Jul 2003
Posts: 2
Default

i tryed that with a video that does not work well at all with the sound, nothing sounds like the way it should.
In the audio codec compression, what do i choose there if it says it should be bitrate 82,9 - 9,1 kbps?
Dante Sweethear is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 10:15 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com