Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Closed) > Other Software

 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 8 May 2005, 08:34 PM   #1
Junior Member
Junior Member
 
Join Date: May 2005
Posts: 4
Default output AVI with half audio ?

Hi,

I joined 2 XViD files (which is a single movie) into single Avi file using Virtualdub 1.3c and following the steps given at this link :-

http://www.afterdawn.com/guides/arch...b_join_avi.cfm

The independent XViD files are of length 1:32:08 and 1:35:21 respectively. Output AVI is 3:07:30

The problem is, in this output avi, till 1:02:40, the audio is proper & with sync with the video.. perfect. But then there is no audio till the end of the file.

Can some one please help me knowing why the audio is not there after a certain length ?


TIA..



IndianHacker
indianhacker is offline  
Old 9 May 2005, 03:47 AM   #2
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

A) You'd be better served using a more recent version of VirtualDub when dealing with XviD files (V.1.3c pre-dates the creation of the XviD compression format).

B) Do each of the original files play properly, with audio all the way from beginning to end?

C) 1) Load the first original video file into VirtualDub (or one of its many variants) or NanDub

2) From the "File" dropdown menu, select "File Information"

3) Post (here) EVERYTHING you see (BOTH video and audio information), or post a screen capture .jpg of the information box
setarip is offline  
Old 9 May 2005, 04:43 AM   #3
Junior Member
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Hi Setarip,

Thanks for the response. I downloaded VirtualDub 1.5.10 Build 18160.

Let me answer your question. Yes, Both the file have proper audio & in sync till end throughout..

Now, when I tried to load the 1st file, it gave me the error in the attached error.jpg. When I tried to load the 2nd file first, it gave me same error.. Only the ms value in the error this time was different.

I have attached a zip which contains error.jpg & fileinfo.jpg


Thanks for the help & waiting for your reply..



Indian
Attached Files
File Type: zip attach.zip‎ (123.2 KB, 59 views)
indianhacker is offline  
Old 9 May 2005, 06:05 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Your files contain "VBR" (Variable Bitrate) .MP3 audiostreams, which are problematic when joining files.

Using VirtualDubMOD to Convert "VBR" .MP3 to Uncompressed .WAV

1) Load the .AVI file into VirtualDubMOD (a different program than the standard VirtualDub)

2) From the "Video" dropdown menu, select "Direct Stream Copy"

3) From the "Streams" dropdown menu, select "Stream List" - and rightclick on the audio stream, then select "Full Processing Mode" - then click on "OK". Rightclick on the audiostream again, then select "Compression" and make certain it is set to "No compression (PCM)"

4) From the "File" dropdown menu, save .AVI with a new filename

After you've successfully converted each of the two files, joining two .AVIs can be accomplished in VirtualDub (or any of its variants) by simply:

1) Loading the first file and then, from the "File" dropdown menu selecting "Append .AVI segment" and loading the second file.

2) Setting "Video" to "Direct Stream Copy"

3) Setting "Audio" to "Full Processing Mode" - and from the "Audio" dropdown menu selecting "Compression" and choosing the .MP3 ("MPEG1-Layer3") setting you desire

3) Saving with a new filename

Last edited by setarip; 9 May 2005 at 06:12 AM
setarip is offline  
Old 16 May 2005, 02:37 PM   #5
Junior Member
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Hi Setarip,

Now, what I did is, I saved both the files with PCM audio, joined them & got the WAV file saved differently.

After this, I did a lot of effrots through Nandub & VirtualDubMod by giving this WAV file as audio source & giving the proper miliseconds value in the interleaving option to bring the audio & video in sync. But, no luck !!

Now, I have the complete movie in a single file with audio till end but it is about 5 secs ahead of the video during the entire movie..


Please help !!




IndianHacker
indianhacker is offline  
Old 16 May 2005, 04:16 PM   #6
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

A) If the difference between audio and video is constant throughout the video:

Load the file into VirtualDub, VirtualDubMod, or NanDub.
Set BOTH "Video"(VirtualDub, VirtualDubMod and NanDub) and "Audio" (VirtualDub and NanDub - VirtualDubMOD>"Streams>"Stream list") to "Direct Stream Copy".
From the "Audio" dropdown menu, select "Interleaving" (For VirtualDubMOD, rightclick on the listed audiostream and then select "Interleaving")
Under "Audio skew correction", set an appropriate number of milleseconds (positive or negative) in the box labelled "Delay audio track by"
Save with a new filename

Let us know of your success ;>}
setarip is offline  
Old 17 May 2005, 07:10 AM   #7
Junior Member
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Cool, Thanks! I had this problem my self, this is realy working now!
Boaz Bagbag is offline  
Old 17 May 2005, 12:31 PM   #8
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default To Boaz Bagbag

Welcome to the Digital Video Forums of Digital Digest

"Cool, Thanks! I had this problem my self, this is realy working now!"

My pleasure ;>}

Let's hope "indianhacker" is equally successful!
setarip is offline  
Old 21 May 2005, 07:29 PM   #9
Junior Member
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Hi Setarip,

I did exactly as you have mentioned with Nandub & now I have movie1.avi & movie2.avi with audio & Video in proper sync

But now, when I try to join them with VIrtualDubMod, I 1st get error as attached in file error1.jpg when I select movie1.avi. After that I say append segment & select the movie2.avi & get error as attached in error2.jpg

Please check the zip file for the screen shots.


How do I proceed now ?





IndianHacker
Attached Files
File Type: zip errors.zip‎ (142.0 KB, 53 views)
indianhacker is offline  
Old 22 May 2005, 01:13 AM   #10
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default To indianhacker

Your screendump of the first segment shows that you HAVEN'T yet converted the audio to .WAV...
setarip is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 09:58 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com