Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Active) > VCD/SVCD > Conversion/Encoding

Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 5 Feb 2005, 05:00 AM   #1
Junior Member
Junior Member
 
Join Date: Feb 2005
Posts: 5
Default AVI to svcd help please -no sound w/ mainconcept

Help, I used mainconcept mpeg encoder to convert avi to svcd...the final svcd has picture but no sound...any help please.
radar is offline   Reply With Quote
Old 5 Feb 2005, 07:14 AM   #2
Digital Video Expert
Digital Video Expert
 
reboot's Avatar
 
Join Date: Apr 2004
Posts: 695
Default

On Mainconcept's main screen, does it show that you loaded both video and audio (at the top)?
If it does, and it encode properly, you may not have an mpeg-2 codec on your system to play back mpeg-2.
Windows media player doesn't automatically come with one.
__________________
My DVDLab (and other) Guides
reboot is offline   Reply With Quote
Old 5 Feb 2005, 07:51 AM   #3
Junior Member
Junior Member
 
Join Date: Feb 2005
Posts: 5
Default

Thanks I loaded klite codec pack onto my pc which I thought would work...I do have the same avi file loaded for audio & video, and have tried twice but still no sound.
radar is offline   Reply With Quote
Old 5 Feb 2005, 10:21 AM   #4
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

1) Load the .AVI file into VirtualDub (or any of its variants) or NanDub

2) From the "File" dropdown menu, select "File Information"

3) Post (here) EVERYTHING you see (both video and audio information), or post a screen capture .jpg of the information box


The audiostream is probably in either .AC3 format or Variable Bitrate MPEG Layer 3 (VBR .MP3).
setarip is offline   Reply With Quote
Old 5 Feb 2005, 10:45 AM   #5
Junior Member
Junior Member
 
Join Date: Feb 2005
Posts: 5
Default

Thanks ...ran virtualdub.....I get an error message when I open the avi file "Improper vbr audio encoding in the source avi file"....so I assume I should just through out the file.
radar is offline   Reply With Quote
Old 5 Feb 2005, 11:36 AM   #6
Digital Video Expert
Digital Video Expert
 
reboot's Avatar
 
Join Date: Apr 2004
Posts: 695
Default

No, open it in virtualdub.
Select Audio, full processing.
Select File, save .wav
Save it.
Get Audacity or Goldwave.
Open the .wav
Save as .wav
Open Mainconcept.
Load the video, and under audio, load the .wav you just saved.
Encode.
reboot is offline   Reply With Quote
Old 5 Feb 2005, 11:39 AM   #7
Junior Member
Junior Member
 
Join Date: Feb 2005
Posts: 5
Default

Well heck...I tried to save wav in virtualdub and I get an error message that I don't have the correct codec...I have klite codec pack installed...

Last edited by radar; 5 Feb 2005 at 11:52 AM
radar is offline   Reply With Quote
Old 6 Feb 2005, 07:19 AM   #8
Lord of Digital Video
Lord of Digital Video
 
tigerman8u's Avatar
 
Join Date: Aug 2003
Posts: 2,123
Default

Get the AC-3 ACM Decompressor (free). If it's not on this site you can d/l it here in the tools section www.videohelp.com
tigerman8u is offline   Reply With Quote
Old 6 Feb 2005, 07:49 AM   #9
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

Converting .AVIs with VBR-MP3 Audio

Simply use NanDub or VirtualDubMOD (Different than standard VirtualDub), to save the audio stream as an Uncompressed PCM (WAV) file as follows:
1) Load your original .AVI into NanDub

2)Set "Video" to "Direct Stream Copy"

3) Set "Audio" to "Full Processing Mode" (NanDub only -For VirtualDubMOD>"Streams>"Stream list">>rightclick on the listed audiostream and then select "Full Processing Mode")
From the "Audio" dropdown menu, select "Compression" and choose "No compression(PCM)" (NanDub only - For VirtualDubMOD>"Streams>"Stream list">>rightclick on the listed audiostream and then select "Compression" and choose "No compression(PCM)")

4) From the "File" dropdown menu, select "Save WAV" (In VirtualDubMOD, "Save WAV" is located under the "Streams" drodpown menu) (Enter a new filename with a ".WAV" extender).Click on "OK"

5) Then save the .AVI as a silent .AVI (NanDub - set "Audio" to "No audio" after you've saved the WAV file. - For VirtualDubMOD>"Streams>"Stream list">>click on the listed audiostream and then select "Disable").


Then close NanDub and restart it
Set "Audio" to "No audio" (Not necessary under VirtualDubMOD)
Load your silent .AVI
Set "Video" to "Direct Stream Copy"
Under "Audio" click on "WAV Audio" and load your .WAV (In VirtualDubMOD, Streams>>Add)
Set "Audio" to "Full Processing Mode" (In VirtualDubMOD, Streams>>Rightclick on the listed audiostream, click on "Direct Stream Copy")
From the "Audio" (In VirtualDubMOD, "Streams") dropdown menu, select "Compression" (In VirtualDubMOD, rightclick on the listed audiostream, click on "Compression") and choose the appropriate .MP3 settings. Click on "OK"
From the "File" dropdown menu, select "Save as AVI" (In VirtualDubMOD, "Save as") and save your file with a new filename.
setarip is offline   Reply With Quote
Old 6 Feb 2005, 07:51 AM   #10
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default To tigerman8u

"Get the AC-3 ACM Decompressor"

What does this have to do with a Variable Bitrate (VBR) .MP3 audiostream?
setarip is offline   Reply With Quote
Old 6 Feb 2005, 08:19 AM   #11
Lord of Digital Video
Lord of Digital Video
 
tigerman8u's Avatar
 
Join Date: Aug 2003
Posts: 2,123
Default

I was replying from your above post "The audiostream is probably in either .AC3 format or Variable Bitrate MPEG Layer 3 (VBR .MP3)." and from "radar" reply "I tried to save wav in virtualdub and I get an error message that I don't have the correct codec". I thought if the audio was AC-3 this would decode the audio for him.
tigerman8u is offline   Reply With Quote
Old 6 Feb 2005, 08:21 AM   #12
Junior Member
Junior Member
 
Join Date: Feb 2005
Posts: 5
Default

I did Reboot steps...after d/l new codecs...work great thanks a bunch guys.
radar is offline   Reply With Quote
Old 6 Feb 2005, 05:59 PM   #13
Retired
 
setarip's Avatar
 
Join Date: Dec 2001
Posts: 24,955
Default

"work great thanks a bunch guys."

My (Our) pleasure ;>}
setarip is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 05:58 AM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com