Digital Video Forums  

Go Back   Digital Video Forums > Other > Archive (Closed) > Foreign Language Forums > Auf Deutsch

 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 10 Sep 2002, 07:50 PM   #1
Junior Member
Junior Member
 
Join Date: Sep 2002
Posts: 5
Default DivX5Pro, Virtual Dub, Temporal Smoother und es ruckelt. :-/

Hi zusammen,

ich habe ein Problem beim Rendern meiner Videos. Vielleicht vorweg: Die Mpeg--Quell-Dateien kommen von einer Digisuite LE und haben somit eine durchweg sehr gute Qualität und keine dropped Frames.
Das ändert aber leider nichts daran, dass ich auch bei TV-Aufnahmen das übliche Rauschen habe, was einer guten Kompression doch erheblich entgegen steht.

Die Konvertierung von Mpeg1 nach Divx (5.0.2 Pro) mache ich mittels VirtualDub (aktuelle Version). Wie oben schon geschrieben macht es nur Sinn, wenn man man das Rauschen verringert bekommt. Ich benutze dafür den integrierten temporal smoother auf der Stufe 4 oder 3 und habe damit sehr gute Ergebnisse erzielt. Allerdings habe ich ein Ruckeln bei schnellen Bewegungen und Kameraschwenks und manchmal auch bei sehr ruhigen Bewegungen.
Ich habe nun schon ein wenig rumexperimentiert und -soweit ich das sagen kann- ist wohl der temporal smoother Grund dafür. Das Problem dürfte wohl darin liegen, dass er kleine Bewegungen einfach wegrechnet. Im Ergebnis -so mein Eindruck- bekommt man einen 25fps Film, der auf mich eher den Eindruck von 15fps macht. Die Bewegungen wirken jedenfalls nicht mehr sonderlich flüssig.
Ich habe nun auch schon mal den alternativen temporal cleaner verwendet. Vom Gesamtergebnis erscheint er mir aber nicht besser und zudem zieht er bei mir bei Bewegungen Schlieren, die ich als sehr unschön empfinde.

Deswegen meine Frage: Hat jemand eine Idee, ob man da was machen kann oder ob es alternative/bessere Filtermethoden gibt?

Schonmal vielen Dank fuer die Antworten!

Bis denn,

Herr_Rossi
Herr_Rossi is offline  
Old 11 Sep 2002, 06:48 PM   #2
Junior Member
Junior Member
 
Join Date: Sep 2002
Posts: 5
Default

Hi zusammen,

ich habe mittlerweile herausfinden können wo das Problem liegt. Die Digisuite LE erzeugt eine mjpeg-Datei, die wohl leider nicht so ganz standardkonform ist. Das Ruckeln taucht nur dann auf, wenn ich nicht den Digisuite-Hardware-mjpeg-Codec verwende sondern eine reine Softwarelösung einsetze.
Ich stehe jetzt allerdings immer noch vor dem Problem wie ich die Matrox-Datei umwandeln kann, so dass ich sie auch auf anderen Rechnern, die ledigleich einen Software-mjpeg-Codec installiert haben, vernünftig verwenden kann. Der Digisuite-Rechner ist mir nämlich für das anschließende DivX-Rendern zu laut und braucht zudem recht lange.

Gruss,

Herr_Rossi
Herr_Rossi is offline  
Old 11 Sep 2002, 07:20 PM   #3
Super Moderator
 
UncasMS's Avatar
 
Join Date: Nov 2001
Posts: 9,047
Default

du kannst also nicht die mjpeg datei öffenen/umwandeln lassen?
__________________
UncasMS is offline  
Old 11 Sep 2002, 08:34 PM   #4
Junior Member
Junior Member
 
Join Date: Sep 2002
Posts: 5
Default

Hallo,

die Sache ist etwas komplizierter. Unter Windows abspielen kann ich die Datei nicht.
Allerdings nimmt VirtualDub sie an (mit dem integrierten mjpeg decoder), jedoch fehlerhaft. Fehlerhaft in sofern als dass ein Halbbild fehlt, so dass jede zweite Zeile schwarz bleibt.

Ich habe mir deswegen im Netz einen alternativen mjpeg decoder besorgt und den verwendet VirtualDub auch. Die Darstellung ist damit völlig in Ordnung.

Wenn ich aber einen Film rendern lasse (DivX5.02), dann bekomme ich als Ergebis ein rucklendes Bild. Das Ruckeln ist in etwa so wie wenn man eine PAL-Aufnahme nur mit 15fps machen würden. Die FPS-Einstellungen etc. unter VirtualDub stehen natürlich alle auf 25fps und die Ausgabedatei hat ebenfalls 25fps. Ich bin da echt langsam etwas ratlos.

Wenn ich nun auf dem Schnittplatz-Rechner (der mit der Digisuite LE) ihn mittels VirtualDub die selbe Sequenz rendern lasse, dann ist alles in Ordnung. VirtualDub verwendet hier aber natürlich auch den Matrox mjpeg decoder.

Meine Schlußfolgerung ist deswegen, dass an dem Matrox mjpeg Format irgendwas nicht so ganz stimmt (vielleicht irgend ein Optimierung für die Hardware).

Gruss,

Herr_Rossi
Herr_Rossi is offline  
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




All times are GMT +10. The time now is 12:35 PM.

Kirsch designed by Andrew & Austin


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 1999 - 2018 Digital Digest

Visit DivXLand   Visit dvdloc8.com