Showing results 1 to 3 of 3

Thread: FAQ: Problem burning with USB devices

  1. #1
    Super Moderatress
    cynthia's Avatar
    Join Date
    Jan 2004

    Question FAQ: Problem burning with USB devices

    Problem burning with USB devices

    Problem 1:

    The burning is very slow.


    Go into device manager, right click on USB devices, select properties, and do a search for updated drivers. The search will find any new ones and install the appropriate drivers. These can also be found on Microsoft Windows Service Pack 1.

    Problem 2:

    I don't know if my computer have USB 1.1 or USB 2.0?


    To check if your USB port is USB 2.0 or standard USB 1.1, go to "Control Panel" --> "Device Manager" --> "Universal Serial Bus Controller" to see if you have "USB 2.0 Root Hub" listed or "Enhanced Universal Serial Bus Controller" thereunder.

    Problem 3:

    Are the external DVD burners compatible with USB 1.1?


    Yes, they are compatible with USB 1.1. However you will only be able to burn CD and read CD/DVD, you can not burn DVD because the speed is too slow.
    Last edited by cynthia; 7 Jan 2005 at 07:07 AM

  2. #2
    Super Moderatress
    cynthia's Avatar
    Join Date
    Jan 2004

    Exclamation Semaphore Timeout Issue

    Semaphore Timeout Issue

    Error code:


    You recieve this error when you try to burn with DVD Decrypter with a USB 2.0 connected burner.

    The ALI's are the main culprit. It's some kind of weird combination between the XP, since ME appears to be unaffected, drivers, USB 2.0 onboard connections, and the ALI PCI to USB bridge chips. When installed internally on an IDE connection or when connected to a PCI USB 2.0 card, it seems to work fine. I've verified the IDE connection fix myself, as have others, here and in other forums. I've connected the card and just need to swap around the cable and put the drive back in the enclosure to test. Connecting by FireWire also seems to work, but, I don't have FireWire to test with. Oh, and, USB 1.x works, even when connected to the mobo, i.e. a 1.x hub connected to the 2.0 mobo port. BUT, you get speeds at less than 1x that way, so, that answer, while it works, is not very practical.

    So far, we've only been able to see the problem occur under ALI bridge chips. My drive has one, and at least 2 or 3 others who can verify their chips have shown us that those who have the problem are ALI bridges and those that have verified their working chips aren't ALI's. Plus, when removed from the ALI drive enclosures and put on other chips or used internally as IDE's, they work. So, thus far, the ALI chip has been our main culprit to focus on.


    The following parts are highlights from a thread in the DVD Decrypter forum. Credit: dbminter

    The solution is to remove the drive from its current enclosure and and install it internally or a new enclosure that does not use ALI chips. In System on Belkins we know works from experience, and, we know that removing the drives and placing them internally works. And, I know from other forums and boards that external drives that had issues, not just the semaphore, have been shown to work when removed from the enclosure and installed internally as ATA. Thus, we can pretty much state it's the USB to IDE chip bridge. Whether they're all ALI, though, is still in question.

    Use ElbyCDIO as the interface, after installing ElbyCD from something like CloneDVD. I've gotten that to work, but, not any other interface I can recall. ElbyCDIO is just the interface layer, it wont be any different for you from using any of the others - except it'll work where SPTI wont on crappy semaphore timeout issues!

    Well, we know it's a problem with the SPTI drivers, since they aren't in Windows ME, and switching from SPTI has (Sometimes) been the kill all solution for the timeout. (So far, the only sure fire solution is to remove the drive from the enclosure and install it internally, or connect the external drive by FireWire if offered.) Thus, I can't really see how the ME drivers would help. But, maybe Lightning might know of a reason.

    There are a few things that can be done, but, you're not going to like them. For any external drive where you've gotten the semaphore timeout, you can try these different things:

    1.) connect the drive by FireWire if it and the PC have the capability
    2.) remove the drive from the USB enclosure and install it internally in the PC
    3.) install a USB 2.0 card in one of the PCI expansion slots and connect the drive to it
    4.) use Windows ME instead of XP
    5.) remove the drive from the USB enclosure and install it in a new enclosure, like Belkin, that doesn't use one of the known bad chips
    6.) connect the drive to a USB 1.x hub, however, be aware your burn speed will be less than 1x.

    Okay, here are some things that may or may not work.

    1.) XP Service Pack 2. I've not been able to see if #2 requires this or not, and, I doubt I can be bothered with testing it over and over again, truth be told.
    2.) if you experience a semaphore timeout, the reboot might help IF done one of two ways a.) power off the drive and then back on BEFORE you turn the PC on. b.) leave the drive powered off until AFTER Windows boots up. Then, turn it on.

    Right now, a burn is burning after the semaphore timeout occurred after XP SP 2 had been installed. But, I've not been able to determine if the drive needed a power cycle after the service pack installation to avoid the timeout or if you need to power off and power on the drive each time before Windows starts or to leave the drive powered off and then power it back on after Windows loads.

    But, so far, at least one of the above, or a combination or multiple combinations of the above seems to work...

    However, I've also noticed that the majority of times the burn seemed to work in instances where I was testing explicitly for it, it seems, though no solid proof can be discerned from this, is that if you're going to use an external USB 2 DVD writer with XP, you may want to shutdown, turn off the power to the DVD drive, restart into Windows, making sure the DVD drive is powered off. Then, power on the drive after Windows starts. Whenever I did this, I did not encounter any semaphore timeouts, as opposed to doing this, then, a burn, then rebooting with the power to the drive on, then another attempt burn, reboot, burn again, etc. That way, every other burn was almost always a semaphore timeout cancel.

    So, I'd recommend trying that for anyone with semaphore timeout problems: before doing a burn, shut down the PC, turn off the DVD drive's power, boot back into Windows, then turning the drive's power on, and trying.

    Works perfectly with latest version of Nero. No semaphore timeouts whatsoever.

    I have had this damn semaphore problem for ages. After reading this thread again, I tried Nero v6.3.1.25, and sofar it works

    like a charm(touch wood) - no timouts whatsoever. I would like to be able to use dvddecrypter or recordnow, but if it means buying a new enclosure, then Nero will have to do.

    I don't think there can be a fix that doesn't require hardware. ALI didn't design these chips to be updated, but, they have updated future chip sets to do this, so, they know there's a problem. You can't even poll the chips for version number, BIOS revisions, etc. In fact, ALI's solution when I talked to them is to simply replace the chip with one of their newer ones. How convenient. I'd just as well replace it with a known WORKING chip set, thank you very much!

    So, the only solutions so far, and, I believe, the only one we'll come across since ALI won't be forthcoming with info:
    a.) remove the drive from its external enclosure and install it internally on IDE
    b.) connect the drive by Firewire, installing a Firewire card if necessary
    c.) remove the drive from its external enclosure and install it in another external enclosure that has a Firewire connection and connect the drive by Firewire, installing a Firewire card if necessary
    d.) remove the drive from its external enclosure and install it in another external enclosure that uses a known good PCI to USB bridge chipset.

    The nearest I can tell it's a combination driver and hardware issue. It only affects certain hardware and certain driver combinations. On Windows ME, the problem apparently doesn't exist. On XP, it only exists on ALI chipsets connected by USB.

    Sometimes, it doesn't affect USB drives connected to hubs. It doesn't affect USB 1.x. So, which do you blame? Later ALI chips, according to ALI so take it with a grain of salt aren't affected. But, since Windows ME doesn't have a problem, it's a problem with the driver when used with specific hardware. So, if it's a driver, which is it? Probably impossible to track it down. I can't remember if I tried SP 2 or not. It's probably earlier in this thread. I made a lot of on board notes as I conducted my tests so I'd know in future what I had and hadn't done and what happened.

    I downgraded back to DVD Decrypter ver and the problem went away again.
    Last edited by blutach; 6 Nov 2005 at 11:25 PM

  3. #3
    Super Moderator
    jmet's Avatar
    Join Date
    Nov 2002
    East, TX


    This thread has been closed/locked, as it is for information purposes only. If you have a question regarding this thread.

    Moderators of the FAQ/Knowledgebase forum
    Last edited by admin; 26 May 2007 at 02:42 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts