Good Morning, I hope you all are doing well. I was looking for a little help this morning and felt that i could get it here. Here is my problem.

I downloaded a home video ecourse to my computer hard drive. I then imported the MPEG-4 videos only to my video editing software where I did a little audio and video editing before they can be ready for public use. Included in the ecourse download are anumber of MPEG-4 video folders. Inside each video folder there are a number of files in addition to the MPEG-4 video file, they include in this order. a .html file, a Mpeg-4 video file, a controller.swf, an expressinstall.swf, a FirstFrame.png (Adobe Fireworks) file. a ProductionInfo.xml, and a swfobject.js file. Before I did any editing to the MPEG-4 file when I clicked on the .html the first frame and video play button would open in my browser (Internet Explorer). I click the play button and the video ran perfectly. After the editing of the MPEG-4 videos exporting back to the same folders of origin they won't show. I can hear the sound and I can see the video controller, what I don't see is my video. Can anyone help me with this? I have tried all I know and nothing has worked. i don't think it is my Adobe Flash install. By the way I am running a Micrpsoft Vista Home Premium 64-Bit OS. any help would be greatly appreciated.

Thank You,
TonySan