Showing results 1 to 1 of 1

Thread: Samsung B083l not playing any blu rays

  1. #1
    Junior Member
    Junior Member

    Join Date
    Jul 2011
    Posts
    1

    Default Samsung B083l not playing any blu rays

    Hi all,

    I have had this drive for around year and half - been good and had no issues with anything.
    I recently got harry potter blu rays and got "this disc is unrecognized format"
    first time ever.
    So i decided to upgrade firm to sb01 latest version, since then it does not
    play any blu rays at all. Even ones i now worked before.
    I tried to go back to sb00 firmware and still the same.
    I have installed bl01 twice as recommended when installing and
    still the same outcome.
    I have updated by video card drivers as well.
    All dvds/games/cds work fine still.
    I was using cyberlink powerdvd 8 and then upgraded to 10 and both were the same

    I have lotr extended edition sitting on my desk waiting to be
    played and its annoying me!

    Thanks for any help
    Phil
    Last edited by phil750; 13 Jul 2011 at 05:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Liteon iHBS112 firmware not able to burn Blu-rays
    By m127 in forum Firmware HQ Forum
    Replies: 1
    Last Post: 16 Feb 2011, 12:37 PM
  2. Replies: 0
    Last Post: 5 Nov 2008, 12:53 AM
  3. DVD backup copy not playing on my home DVD but playing on others
    By massimodvd in forum DVD Encoding and Playback
    Replies: 3
    Last Post: 1 Dec 2003, 07:06 AM

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •